Downloads

Download X2COPY 2.0.2

X2COPY requires Windows 10 build 14393 or later, and a 64-bit processor. X2COPY is not supported on earlier systems, including Windows 7.

Important Note

Your browser or operating system may display a warning dialog stating that this program is “not commonly downloaded and may therefore be malicious.” Please disregard this dialog. It is emitted automatically by Windows and there is no way to stop it.